Support Article
ClearCase connectivity on CDM v6.8 Decision Planner
SA-9016
Summary
You as an application developer are using Decision Planner: v6.8.4848, Strategy Director: v6.8.5554 and the plugin for ClearCase connection-Rational ClearCase SCM Adapter V7.0.0.20081031A but unable to connect to ClearCase.
Error Messages
Connect to Rational ClearCase failed
(Error):
Connect to Rational ClearCase failed
Reason: select Details>> for more information.
Details:
Could not connect to Rational ClearCase. Please ensure that the proper version of ClearCase is installed with the proper patches. Consult the ClearCase SCM Adapter documentation for further details.
Provider name: IBM
Plugin name: Rational ClearCase SCM Adapter
Plugin ID: com.rational.clearcase
Version: 7.0.0.20081031A
Steps to Reproduce
1. Install plug-ins -
com.ibm.rational.clearcase.ccimport_7.0.0.20070612B
com.rational.clearcase.activities_7.0.0.20081031A
com.rational.clearcase.help_7.0.0.20081031A
com.rational.clearcase_7.0.0.20081031A
to the machine's C:\Program Files\Pega\CDM_v6_8\DP\plugins
2. Install 'features' folder containing -
com.ibm.rational.clearcase.ccimport.feature_7.0.0.20070612B
com.rational.clearcase_7.0.0.20081031A
into - C:\Program Files\Pega\CDM_v6_8\DP
'ClearCase' Menu option is enabled on DP Menu bar.
3. Clicking on 'Connect to ClearCase' option under ClearCase is giving an error on screen.
Root Cause
Rational ClearCase client is not installed in the machine. ClearCase client is required for SCM adapters to work.
Resolution
Install Rational ClearCase client.
Published January 31, 2016 - Updated October 8, 2020
Have a question? Get answers now.
Visit the Collaboration Center to ask questions, engage in discussions, share ideas, and help others.