Skip to main content

This content has been archived and is no longer being updated. Links may not function; however, this content may be relevant to outdated versions of the product.

Support Article

Connect SOAP method not working

SA-57357

Summary



When using Connect-SOAP method and the Parse XML step is not activated, the response does not load to the Clipboard. The application uses Pega Marketing 7.31.


Error Messages



Not Applicable


Steps to Reproduce

  1. Create a SOAP integration.
  2. Create an activity to run the integration.
  3. Trace the InvokeAxis2 out-of-the-box activity.
  4. Check on the Tracer, the Activities and Activity Steps options on Event to Trace, Parse Rules, SOAP Messages, and Stream Rules on Event Types to Trace.
  5. Parse XML on step 16. The event must display on the Tracer.


Root Cause



When optional elements with blank values in the request are not sent, the service displays the request in the incorrect response envelope. However, in Pega 7.3.1, the service does not process the request correctly. At the service level, this is considered an incorrect call.


Resolution



As a local-change, provide optional elements with blank values if they do not have relevance.


 

Published December 2, 2018 - Updated October 8, 2020

Was this useful?

100% found this useful

Have a question? Get answers now.

Visit the Collaboration Center to ask questions, engage in discussions, share ideas, and help others.

Did you find this content helpful?

Want to help us improve this content?

We'd prefer it if you saw us at our best.

Pega Community has detected you are using a browser which may prevent you from experiencing the site as intended. To improve your experience, please update your browser.

Close Deprecation Notice
Contact us