Support Article

CWS is built on wrong version of HCIF

SA-37312

Summary



After doing a clean install of Pega 7.22, Healthcare Industry Framework (HCIF) 7.22 , and Claims Workstation+ for Healthcare (CWS) 7.21, when users log in as CWSAdministrator the below error appears.

The built on application list refers to HCIF 7.21 instead of 7.22.


Error Messages



Status fail
Message There has been an issue; please consult your system administrator
Operator ID CWSAdministrator@MyHealthPlan
Requestor ID H592582B3C061CB3563836B3D4C673676
Timestamp Tue Apr 25 13:59:59 EDT 2017
Engine Version PegaRULES 7.20 ML2 (PRPC-7.2.2-60)


Steps to Reproduce

  1. Log in as CWSAdministrator.
  2. Try to modify that operator.


Root Cause



A defect in Pegasystems’ code or rules.

Resolution



Perform the following local-change:
  1. Login as administrator@myhealthplan , password ‘install’ .
  2. From the Records Explorer, Click the Application Definition > Application.
  3. Click on the CWS 7.21 rule instance.
  4. In the CWS 7.21 application rule instance, select PegaHC version as 7.22 instead of 7.21 and click ‘Save’.
  5. Login back as CWSAdministrator@myhealthplan/install and verify to open the application instance or Operator/Access Group record.

Published May 1, 2017 - Updated May 15, 2017

Have a question? Get answers now.

Visit the Collaboration Center to ask questions, engage in discussions, share ideas, and help others.