Skip to main content

This content has been archived and is no longer being updated. Links may not function; however, this content may be relevant to outdated versions of the product.

Support Article

Database Template rule stores NULL as text

SA-31015

Summary



In the database table associated with the Database Template rule, the null values are stored as "NULL" literal value instead of null. When files are generated from the data, the value is displayed as NULL instead of empty.
In the BatchOut table, the
null value is stored correctly. But when the same value is mapped to the Database Template, it is stored as a NULL text value.


Error Messages



Not Applicable


Steps to Reproduce

  1. Create a Database Template rule and map some of the column values as Text blank or properties with no values.
  2. Include this template in the Offer.
  3. After the campaign is run, check the database tables of the template. The null values display as NULL text values.
  4. Observe that the SQL query with the Where clause columnName is null does not return any results; but columnName = NULL does return results.


Root Cause



A defect in Pega Marketing 7.12

Resolution



Apply HFix-31576 for Pega Marketing 7.12.

Published August 23, 2017 - Updated December 2, 2021

Was this useful?

0% found this useful

Have a question? Get answers now.

Visit the Collaboration Center to ask questions, engage in discussions, share ideas, and help others.

Did you find this content helpful?

Want to help us improve this content?

We'd prefer it if you saw us at our best.

Pega Community has detected you are using a browser which may prevent you from experiencing the site as intended. To improve your experience, please update your browser.

Close Deprecation Notice
Contact us