Support Article

DataFlow error in Batch processing

SA-34269

Summary



Creating a dataflow and running through Batch processing throws an error.


Error Messages



Unable to create assignments for run [DataFlowRunConfig{className=GM-NBAAOns-AYSData-VIN_DATA, ruleName=AYSDataFeed, workObjectId=DF-112, testRun=false, realTimeRun=dalse, publishUrlName=, accessGroup=NBAAOns:Administrators, batchSize=250}]

at com.pega.dsm.dnode.impl.dataflow.service.WorkObjectDataFlowRun.prepare(WorkObjectDataFlowRun.java:102) at com.pega.dsm.dnode.impl.dataflow.service.WorkObjectDataFlowRun.prepareAndExecute(WorkObjectDataFlowRun.java:65) at com.pega.dsm.dnode.impl.dataflow.service.DataFlowServiceImpl$1.execute(DataFlowServiceImpl.java:194) at


2017-01-26 16:26:32,954 [Access group: [null]] [ STANDARD] [ ] [ ] (andraBrowseAllRecordsOperation) ERROR - No hosts available
com.datastax.driver.core.exceptions.NoHostAvailableException: All host(s) tried for query failed (tried: /172.16.7.xx.xx (com.datastax.driver.core.OperationTimedOutException: [/172.16.7.xxx.xx] Operation timed out))
at com.datastax.driver.core.ControlConnection.reconnectInternal(ControlConnection.java:240)


Steps to Reproduce



1. Create a data flow.
2. Try to run it through Batch processing and observe the error.


Root Cause



A defect or configuration issue in the operating environment. com.datastax.driver.core.exceptions.NoHostAvailableException:

From the above error trace, it is a Cassandra connection.



Resolution



Perform the following local-change steps:

1. From the DNode cluster management landing page, check the status of each node and the disk size information. All nodes should be in Normal-online mode.

2. Also check the disk space (Cassandra data). Sometimes the batch processed data flow fails due to the low disk size also.

Published February 27, 2017 - Updated March 15, 2017


50% found this useful

Have a question? Get answers now.

Visit the Collaboration Center to ask questions, engage in discussions, share ideas, and help others.