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Support Article

Email listener stops processing sporadically

SA-103980

Summary



Email listeners stop processing emails sporadically. To overcome this, the user must restart the node. On stopping or restarting the Listener, the Run status updates to 'Stopping', and the system hangs.


Error Messages



Not Applicable


Steps to Reproduce



Not Applicable


Root Cause



A defect in Pegasystems’ code or rules.

On debugging the 'com.pega.pegarules.integration.engine.internal.services.email.EmailListener', it was determined that the email listener was still processing an email.
According to the Producing Thread dumps while the Listener was in the stuck state, the Listener was waiting to receive a response to initiate an SSL handshake for a REST call that was made. There was an underlying network issue, due to  which a response was not returned to the application. However, there was also an issue with the Pega application where the Connection attempt was timed out incorrectly.


Resolution



Apply HFix-60169.

Published April 14, 2020 - Updated October 8, 2020

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