Skip to main content

This content has been archived and is no longer being updated. Links may not function; however, this content may be relevant to outdated versions of the product.

Support Article

Email Listener using IMAPS is not deleting all messages

SA-38603

Summary



When testing an Email Listener, it is able to read a shared inbox but not all emails are deleted, even after the 'Keep messages on IMAP server' is not selected.


Error Messages



Not Applicable


Steps to Reproduce



Configure email listener, and let it run and consume messages.


Root Cause



The emails that are not deleted are ones that have already been read.

Resolution



This is expected behavior.

Email Listeners process only messages that have not yet been retrieved or read.

Published July 13, 2017 - Updated October 8, 2020

Was this useful?

0% found this useful

Have a question? Get answers now.

Visit the Collaboration Center to ask questions, engage in discussions, share ideas, and help others.

Did you find this content helpful?

Want to help us improve this content?

We'd prefer it if you saw us at our best.

Pega Community has detected you are using a browser which may prevent you from experiencing the site as intended. To improve your experience, please update your browser.

Close Deprecation Notice
Contact us