Support Article
Error while creating case, after installing KYC 7.14
SA-32105
Summary
After installing Know Your Customer (KYC) 7.14 on Pega 7.21 and while following the instructions in installation guide to create an Onboarding case, an error occurs in UI.
ERROR MESSAGES
CustomerType: The Field Value with key value(s) PegaFS-Data-Party/CustomerType/Entity does not exist
Steps to Reproduce
1. Create an Onboarding case.
2. Enter EURO and search.
3. Select an account of type Entity.
4. Select a party and click Next.
5. Observe that error on screen.
Root Cause
In PostCustomerSearch activity, see that there is an error in 'SelectedCustomer' page while copying data.
In previous versions of PRPC, Page-Change-Class method in step 3.1 is validating properties and removing the error message as user change the class.
But from Pega 7.21, Page-Change-Class method is not validating properties. User need to have explicit validation “Page-Validate” to be added in “PostCustomerSearch” activity after Page-Change-Class.
Resolution
Apply HFix-31303.
Published January 20, 2017 - Updated October 8, 2020
Have a question? Get answers now.
Visit the Collaboration Center to ask questions, engage in discussions, share ideas, and help others.