Skip to main content

This content has been archived and is no longer being updated. Links may not function; however, this content may be relevant to outdated versions of the product.

Support Article

Exception on connecting to Predictive Diagnostic Cloud

SA-82812

Summary



SocketTimeoutException while connecting to Pega Predictive Diagnostic Cloud for the first time with a Pega server using the provided URL.


Error Messages



00000158 SystemOut PegaRULES ManagementDaemon ERROR Exception in SOAPAppenderPega.sendEvent()
00000158 SystemOut     PegaRULES ManagementDaemon ERROR   Msg: java.net.SocketTimeoutException: Read timed out
00000158 SystemOut  PegaRULES ManagementDaemon ERROR   Cause: javax.xml.stream.XMLStreamException: java.net.SocketTimeoutException: Read timed out



Steps to Reproduce

Unknown.


Root Cause



Client is behind a proxy, and when proxy settings are added, errors displayed.


Resolution

Perform the following local-change:
  1. Configure PDC: Navigate to Designer Studio > System > Settings > PDC in an on-premise monitored node using the tenant URL provided
  2. Inspect the PDC system connectivity: Diagnostic Cloud > Tools > System Connectivity for connected systems
  3. Enable the TLS 1.2 protocol

 

Published August 19, 2019 - Updated October 8, 2020

Was this useful?

0% found this useful

Have a question? Get answers now.

Visit the Collaboration Center to ask questions, engage in discussions, share ideas, and help others.

Did you find this content helpful?

Want to help us improve this content?

We'd prefer it if you saw us at our best.

Pega Community has detected you are using a browser which may prevent you from experiencing the site as intended. To improve your experience, please update your browser.

Close Deprecation Notice
Contact us