Support Article

Failed to start CTILink: Unexpected Error when started CTI Link

SA-30853

Summary



The user is encountered with the error i.e. Failed to start CTILink: Unexpected Error when they start the configured CTI link. User is having two instances which are pointing to same DB. The user has queried why they were getting Auto In and Manual In option when they have logged in and clicking on Available.

Error Messages



Failed to start CTILink: Unexpected Error


Steps to Reproduce

  1. Start the CTI link that is configured.
  2. Error message will be seen and it remains in a stop state.


Root Cause



The user has not configured the CTI Link properly.
 

Resolution

  1. Configured CTI Link i.e. CTI Server Host and Port, Peripheral ID and Client ID properly.
  2. If CTI Link is opened, in the Switch Capabilities Tab,there is an an checkbox named Select Work mode on Available. If it is not checked, then Auto In and Manual In options will not come for Available option when user logs in.

Published November 28, 2016 - Updated December 4, 2016

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