Support Article
Filters on reports cause errors
SA-18919
Summary
User is having multiple issue with reports.
Issue 1: When the user is trying to use multiple filter on the columns with out of the box reports in Case Manager portal.
Issue 2: The same list is opened and a new page button is selected. The page can be changed once but the buttons on the next page do not work. The same screen is displayed on the UI.
Issue 3: If an edit is cancelled the screen refreshes and the UI gets distorted.
Issue 4: Sorting a column and traversing to the next page removes the column sorting.
Error Messages
Not Applicable
Steps to Reproduce
1. Open Case Manager portal.
2. Go to reports.
3. Open any list report.
4. Click on filter for column one.
5. Click on filter for column two.
6. Click on page number to navigate.
7. Click on Edit filter and click Cancel.
8. Click on sorting for multiple icons.
Root Cause
In Form Error marker, the usage of getMessagecount was giving error.
Resolution
Apply HFix-25635. The RULE-HTML-FRAGMENT FORMERRORMARKER has been changed where in Form Error marker, replaced the usage of getMessagecount with hasMessages.
Published January 31, 2016 - Updated October 8, 2020
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