Support Article
Getting error while logging into mobile app
SA-85871
Summary
Error occurs when logging in to the offline enabled mobile application.
Error Messages
org.apache.catalina.connector.ClientAbortException: javax.net.ssl.SSLException: Connection has been shutdown: javax.net.ssl.SSLException: java.net.SocketException: Broken pipe (Write failed)
at org.apache.catalina.connector.OutputBuffer.doFlush(OutputBuffer.java:367) ~[catalina.jar:7.0.63]
at org.apache.catalina.connector.OutputBuffer.flush(OutputBuffer.java:331) ~[catalina.jar:7.0.63]
at org.apache.catalina.connector.CoyoteOutputStream.flush(CoyoteOutputStream.java:101) ~[catalina.jar:7.0.63]
at com.pega.jcraft.jzlib.DeflaterOutputStream.flush(DeflaterOutputStream.java:159) ~[prjzlib-1.1.0.jar:?]
at sun.nio.cs.StreamEncoder.implFlush(StreamEncoder.java:297) ~[?:1.8.0_191]
at sun.nio.cs.StreamEncoder.flush(StreamEncoder.java:141) ~[?:1.8.0_191]
at java.io.OutputStreamWriter.flush(OutputStreamWriter.java:229) ~[?:1.8.0_191]
at com.pega.pegarules.web.impl.DirectStreamWriter.flush(DirectStreamWriter.java:207) ~[prwebj2ee.jar:?]
at com.pega.pegarules.web.impl.DirectStreamWriter.flush(DirectStreamWriter.java:200) ~[prwebj2ee.jar:?]
at com.pega.pegarules.web.impl.WebStandardImpl.sendOutput(WebStandardImpl.java:1052) ~[prwebj2ee.jar:?]
at com.pega.pegarules.web.impl.WebStandardImpl.doPost(WebStandardImpl.java:446) ~[prwebj2ee.jar:?]
at sun.reflect.GeneratedMethodAccessor150.invoke(Unknown Source) ~[?:?]
Steps to Reproduce
- Generate a mobile application.
- Log in to the application with the offline user.
Root Cause
An option is present on the Access Group to select 'Enable Offline Troubleshooting with a browser'. This enables troubleshooting of the offline application in the browser.
After it is selected, log in with a user assigned to this access group on the browser on a desktop computer. The offline enabled application is launched with a new Tracer window which traces the offline application synchronization on the server.
Disable this option if it is not used.
However, with this checkbox selected, the user can still log in to the mobile application with the below settings.
- Offline troubleshooting requires the Authentication type to be set to 'basic' on the offlinehttp service package; whereas the mobile application log can use the 'oAuth 2.0' authentication. Therefore, this must be reverted for mobile log in.
- The 'Use service session cookie (REST/HTTP only)' checkbox on the offlinehttp service package must remain selected for offline browser to work.
(The documentation in the following link will be updated: https://community.pega.com/knowledgebase/articles/troubleshooting-offline-enabled-applications-tracer-tool-browser)
This must be checked for mobile application log in.
Resolution
Perform the following local-change:
Disable the 'Enable Offline Troubleshooting with a browser' checkbox on the access group.
Published December 2, 2021
Have a question? Get answers now.
Visit the Collaboration Center to ask questions, engage in discussions, share ideas, and help others.