Skip to main content

This content has been archived and is no longer being updated. Links may not function; however, this content may be relevant to outdated versions of the product.

Support Article

Hyperlinks on Rich Text Editor Control do not work

SA-99692

Summary

Hyperlinks on the Rich Text Editor (RTE) Control do not work.


Error Messages

Not Applicable

 

Steps to Reproduce

  1. Configure a RTE
  2. Input a few hyperlinks to the RTE
  3. Configure the same RTE on another section in the read-only mode
  4. Enable the Show toolbar in Read Only mode option 
  5. Click the link on the RTE in the read-only mode


Root Cause



Hyperlinks are not clickable when displayed using the RTE in the read-only mode on the Chrome browser. CKEditor is used internally and is configured in the read-only mode. The content renders in an iFrame and the CKEditor performs a preventDefault of the click on anchor elements. Hence, the links do not open.

Resolution



Perform the following local-change:
Configure the RichTextDisplay control instead of the RTE control.

 

 

Suggest Edit

Published April 1, 2020 - Updated December 2, 2021

Did you find this content helpful? Yes No

Have a question? Get answers now.

Visit the Collaboration Center to ask questions, engage in discussions, share ideas, and help others.

We'd prefer it if you saw us at our best.

Pega Community has detected you are using a browser which may prevent you from experiencing the site as intended. To improve your experience, please update your browser.

Close Deprecation Notice
Contact us