Skip to main content

This content has been archived and is no longer being updated. Links may not function; however, this content may be relevant to outdated versions of the product.

Support Article

Issue with building and training model for auto email routing

SA-48956

Summary



In Pega 7.2.1, on receiving a processed email, the email channel interface (in the Training tab) does not create an Email triage work item. The email is processed by an email channel.


Error Messages



Not Applicable


Steps to Reproduce

  1. Configure an email channel interface.
  2. Add the email account in the Configuration tab of the email channel.
  3. Add a suggested case in the Behavior tab and configure a condition for channel routing.
  4. Switch to the Text Analysis tab.
  5. Configure the Text Analyzer rule for entities to be used for entity extraction analysis.
  6. Send an email to the email account such that the email listener processes it. The processed mail displays as the triaged email item in the work list.
  7. Navigate to the Training Data tab.


Root Cause



A defect in Pegasystems’ code or rules.


Resolution



Perform the following local-change:
  1. Open the Email Triage item in the work list to display the suggested case type configured in the Behavior tab of the Email channel interface.
  2. Click the Suggested Case button to open the entity and property mapping model. The language model extracts the entities. Select entities to map to the properties of the suggested case which must be created. As a result, the data in Training Data tab displays when the triaged email item in the work list is processed manually. Additionally, the suggested case is created using entities extracted from the triaged email item.

Published March 17, 2018 - Updated October 8, 2020

Was this useful?

0% found this useful

Have a question? Get answers now.

Visit the Collaboration Center to ask questions, engage in discussions, share ideas, and help others.

Did you find this content helpful?

Want to help us improve this content?

We'd prefer it if you saw us at our best.

Pega Community has detected you are using a browser which may prevent you from experiencing the site as intended. To improve your experience, please update your browser.

Close Deprecation Notice
Contact us