Skip to main content

This content has been archived and is no longer being updated. Links may not function; however, this content may be relevant to outdated versions of the product.

Support Article

Methods missing from eForms API – not backward compatible

SA-39292

Summary



The EFormUtils public API not backward compatible. All of the "generatePopulatedEForm" method signatures have been replaced with new ones that have extra arguments, instead of being overloaded.


Error Messages



Not Applicable


Steps to Reproduce



Use 'EFormUtils' public api call.


Root Cause



A defect in Pegasystems’ code or rules. HFIX-29072 was intended to extend and enhance the EFormUtils API but it also removed preexisting methods of EformUtils.

Resolution



Apply HFix-34972

Suggest Edit

Published July 27, 2017 - Updated October 8, 2020

Did you find this content helpful? Yes No

Have a question? Get answers now.

Visit the Collaboration Center to ask questions, engage in discussions, share ideas, and help others.

We'd prefer it if you saw us at our best.

Pega Community has detected you are using a browser which may prevent you from experiencing the site as intended. To improve your experience, please update your browser.

Close Deprecation Notice
Contact us