Support Article
Mobile SAML login does not work in Offline mode
Summary
User configures mobile channel for application using the out-of-the-box username or password authentication. The user is able to log in to the generated mobile application. Offline Mode displays on the application when the user switches off the Internet connection.
However, if the user changes the login URL to the prweb or Single sign-on (SSO) which uses the SAML Auth, the login in the Online mode works. Offline mode does not display on the application when the Internet connection is tuned off. The Web page not available error occurs when the user relaunches the application on the mobile device in the Offline mode.
The mobile application must support Offline mode. If the user logs in and loses the Internet connection, the user must still be able to access the application. The Offline indicator must display on the application when the network is lost.
Error Messages
Not Applicable
Steps to Reproduce
- Configure a mobile channel
- Build an Android application with SSO URL
- Install the mobile application
- Launch the mobile application
- Log in to the application in Online mode
- Turn off Internet on the mobile device. Offline mode does not display
- Close the mobile application
- Relaunch the mobile application without Internet. A message displays indicating that the webpage is unavailable
Root Cause
A software use or operation error. A HTML page which does not have the offline capability is used while logging in.
Resolution
Perform the following local-change:
- Add the below property to the Asset folder of the mobile build:
container.authentication.oauth2.service=<service alias name > - Build the APK
Published December 2, 2021
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