Support Article

Need to migrate Cassandra data during Pega 7.2 to 7.2.2 update

SA-39149

Summary



Pega Decision Strategy Manager (DSM) 7.2 application is being upgraded to Pega 7.2.2.

This application is utilizing Delayed Learning, which saves offers made for 30 days in Cassandra.

The implementation runs version 1.2.14 of Cassandra & will be upgraded to version 2.1.14 of Cassandra, when Pega application is upgraded from version 7.2 to 7.2.2.

Currently, the upgrade process does not upgrade or migrate the Cassandra data from 1.2.14 to 2.1.14, this application needs a way to convert the data, as the application needs the data in Cassandra to generate correct outcomes after the upgrade.


Error Messages



Not Applicable


Steps to Reproduce



Run the upgrade. Observe that the Cassandra files are in a new location and the data has not been migrated.


Root Cause



A defect in Pegasystems’ code or rules

Resolution



Apply HFix-34609.

Published June 8, 2017 - Updated July 21, 2017

Have a question? Get answers now.

Visit the Collaboration Center to ask questions, engage in discussions, share ideas, and help others.