Support Article
ORA-00001:unique constraint (PEGA.PCA_INTENT_CONTEXT_PK) violate
SA-8392
Summary
A developer, monitoring Pega logfiles, has observed a very rare and intermittant error in the Pega logfile. This error indicates a database SQL UPDATE failure. Developer has contacted Pega to determine what is causing this error, and how to resolve it. The developer has contacted the business, and confirmed that no users have reported any errors reported on the screen. The error condition has been found ONLY in the Pega Logfile, and rarely at that (perhaps twice a day, and at long intervals).
Error Messages
Type Problem #1, SQLState 23000, Error code 1
Message com.ibm.websphere.ce.cm.DuplicateKeyException: ORA-00001: unique constraint (PEGA.PCA_INTENT_CONTEXT_PK) violatedProblem #2, SQLState 23000, Error code 1: java.sql.SQLException: ORA-00001: unique constraint (PEGA.PCA_INTENT_CONTEXT_PK) violated
Error -Query;
com.pega.pegarules.pub.database.DatabaseException
Message Database-Saver-InsertUpdatefailFrom: (REQUESTORID:REQUESTORSRCIP) SQL: update pca_intent_context set CUSTOMERVALUE = ? , ID = ? , INTERACTIONGOAL = ? , INTERACTIONKEY = ? , INTERACTIONTYPE = ? , PXCREATEDATETIME = ? , PXINSNAME = ? , PXOBJCLASS = ? , PZSTATUS = ? , pzPVStream = ? where pzInsKey = ?
Steps to Reproduce
Developers have found no specific steps in the business logic that would trigger this error condition. The extreme rarity of the error makes diagnosis difficult.
Root Cause
The root cause of this problem is a defect in Pegasystems’ code/rules. In consultation with a Pega frameworks development team, it was determined that this error is originating in the "Frequency Scoring" functionality of the Pega Framework Customer Process Management for Healthcare, v74 (113777). Specifically, there are two agents that auto generate the Frequency Scoring data, and write that data to the PCA_INTENT_CONTEXT database table: the CAAggergateData and the RatingAggregateData agents.
Resolution
This issue is resolved through the following Local-change:
Verify with the customer that the CPMHC Framework "Frequency Scoring" functionality is not being used. This functionality was deprecated after this release because customers generally never use the functionality. Once verified, disable the two agents.
Published June 12, 2015 - Updated October 8, 2020
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