Skip to main content

This content has been archived and is no longer being updated. Links may not function; however, this content may be relevant to outdated versions of the product.

Support Article

Pega 7.1.8 stuck thread related to WebLogic and DNodeListener

SA-11549

Summary



Stuck thread issue occurs in WebLogic after fresh Pega 7.1.8 install with OOTB configuration of DNodeListener. The errors appear in WebLogic logs but nothing is reflected in PegaRules logs.

Error Messages



[STUCK] ExecuteThread: '0' for queue: 'weblogic.kernel.Default (self-tuning)'" Id=21 RUNNABLE
at com.pega.dsm.dnode.api.DNodeServiceListener.run_(DNodeServiceListener.java:71)
at com.pega.pegarules.integration.engine.internal.services.listener.ServiceListenerBaseImpl.run(ServiceListenerBaseImpl.java:453)
at com.pega.pegarules.session.internal.engineinterface.etier.impl.AsyncServant.processAsyncTask(AsyncServant.java:213)
at com.pega.pegarules.session.internal.engineinterface.etier.impl.AsyncServant.invoke(AsyncServant.java:167)

...

Steps to Reproduce



Not Applicable

Root Cause



The root cause of this problem is in a third-party product. The WebLogic monitoring tools are caching this scenario and throwing a Stuck thread error.

Resolution



This issue is resolved through the following local-change:

Disable the OOTB configuration for DNodeListener through the prconfig/initservices/dnode property.

Published July 14, 2015 - Updated October 8, 2020

Was this useful?

0% found this useful

Have a question? Get answers now.

Visit the Collaboration Center to ask questions, engage in discussions, share ideas, and help others.

Did you find this content helpful?

We'd prefer it if you saw us at our best.

Pega Community has detected you are using a browser which may prevent you from experiencing the site as intended. To improve your experience, please update your browser.

Close Deprecation Notice