Support Article
Pop Up Window should not come
SA-19728
Summary
While trying to reopen the case, pop up window displays and states that 'case is already opened would you like to reopen the case again'.
One cannot delete this pop-up, however user can customize the same according to the requirements.
Error Messages
"Case is already opened .Would you like to reopen the item"
Steps to Reproduce
When user is trying to reopen, an already opened case pop-up window alert is coming.
Root Cause
Since the message is been hard coded, Pega is providing hook as part of this hotfix, so that they can override the template in their UserWorkForm or in their custom JavaScript.
Resolution
Apply HFIx-26005.
After installing the hotfix, include the below script content either in their portal harness level custom scripts, or at the UserWorkForm.
Here exposed pega.u.d.multiDocConflictDialogTemplate to override the conflict dialog template.
Currently it is "{0}:{1}\n\n{2}{3} {4}\n\n{5}".
{0} : Application - Localized with pyCaption
{1} : [Application Name]
{2} : Work object label
{3} : [(Work ID)]
{4} : is already open. - Localized with pyMessageLabel
{5} : Would you like to reopen the item and lose any unsaved changes? - Localized with pyMessageLabel
As per the requirement now user can override the labels or either one can override this from your custom java script files.
<script>
if(pega && pega.u && pega.u.d){
pega.u.d.multiDocConflictDialogTemplate = "{5}";
}
</script>
After making the changes, browser cache must be deleted.
Refresh the browser or re-login in to the system to get the latest JavaScript rule to pickup.
Published March 4, 2016 - Updated October 8, 2020
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