Skip to main content

This content has been archived and is no longer being updated. Links may not function; however, this content may be relevant to outdated versions of the product.

Support Article

Problem invoking function pegaomf_on_nbaalib.searchProperty--

SA-19722

Summary



Frequent errors in the logs and on Customer Treatment screen.

Error Messages



Problem invoking function: pegaomf_on_nbaalib.searchProperty--(ClipboardProperty,String,ClipboardProperty), Dangling meta character '+' near index 7 ("32gb|+|20gb") ^ 

Steps to Reproduce



1) Launch NBA Portal.
2) Enter the Subscriber, Click enter and Select the customer.
3) Do/Select Customer NBA Interaction.
4) Select an Issue Reason and click Customer Treatment under Next Best Action.
5) In the Next screen i.e Customer Treatment screen, we have Search Treatments Tab there if we Enter a Treatment name starting with some Special characters Like : +^AAL Loyalty/#Add a Sub, then you will get reported error message.


Root Cause



The regular expression logic containing '+' was being used in the searchProperty function to find if the given string exists in the list of Offers, hence when the search was performed with string consist of '+' was giving the error.

Resolution



Provided HFix-25917 which refactors the Search function and removes the use of regular expressions logic and uses indexOf to find if a given String exists in the list of Offers.
 

Published February 15, 2016 - Updated October 8, 2020

Was this useful?

0% found this useful

Have a question? Get answers now.

Visit the Collaboration Center to ask questions, engage in discussions, share ideas, and help others.

Did you find this content helpful?

Want to help us improve this content?

We'd prefer it if you saw us at our best.

Pega Community has detected you are using a browser which may prevent you from experiencing the site as intended. To improve your experience, please update your browser.

Close Deprecation Notice
Contact us