Skip to main content

This content has been archived and is no longer being updated. Links may not function; however, this content may be relevant to outdated versions of the product.

Support Article

Problem obtaining requestor from ServiceRequestorPool

SA-12724

Summary



Configured AES 3.4 to monitor PRPC 6.1 SP2. an error is received when searching for Agents from AES Enterprise Health portal screen. The monitored node is correctly detected.


Error Messages



Caught unexpected com.pega.pegarules.pub.PRRuntimeException, message='Problem obtaining requestor from ServiceRequestorPool


Steps to Reproduce



Not Applicable


Root Cause



The root cause of this problem is a defect in Pegasystems’ code/rules. 

Resolution



This issue is resolved through the following local-change:

Modify PEGAAES Service Package on AES Server to:

    Maximum Idle Requestor - 50
    Maximum Active Requestor - 100
    Maximum Wait (in seconds) - 25


AND

PEGAAESREMOTE Service Package on 6.1 SP2 to:

    Maximum Idle Requestor - 25
    Maximum Active Requestor - 50
    Maximum Wait (in seconds) - 20

Published August 12, 2015 - Updated December 2, 2021

Was this useful?

100% found this useful

Have a question? Get answers now.

Visit the Collaboration Center to ask questions, engage in discussions, share ideas, and help others.

Did you find this content helpful?

Want to help us improve this content?

We'd prefer it if you saw us at our best.

Pega Community has detected you are using a browser which may prevent you from experiencing the site as intended. To improve your experience, please update your browser.

Close Deprecation Notice
Contact us