Skip to main content

This content has been archived and is no longer being updated. Links may not function; however, this content may be relevant to outdated versions of the product.

Support Article

Pulse notifications include additional spaces

SA-59854

Summary



Users are targeting specific operators to update by using the '@' notation when adding a Pulse note on an application built on Sales Automation.
When the user receives an email containing the Pulse notes, the email subject is padded with additional blank spaces.

For example:

[     M-13   ]      SFA Administrator    mentioned you in a comment in      Opp-101

When the user replies to the notification, since the Pulse ID contains blank spaces, the listener fails to find that Pulse entry. Therefore, the response is not added to the same thread.



Error Messages



Not Applicable


Steps to Reproduce



Add a Pulse note to the case targeting another user. When the user receives the email, the additional spaces display.


Root Cause



The additional spaces were due to the control used by the @baseclass pyLabel from the PegaAppCA ruleset.


Resolution



Perform the following local-change:
  1. Save the @baseclass pyLabel rule (from the PegaAppCA ruleset) in an open ruleset available in the custom application.
  2. Change the UI control to FixedSizeForInput.

Alternatively, update to Pega 7.4.

Published February 22, 2019 - Updated October 8, 2020

Was this useful?

0% found this useful

Have a question? Get answers now.

Visit the Collaboration Center to ask questions, engage in discussions, share ideas, and help others.

Did you find this content helpful?

Want to help us improve this content?

We'd prefer it if you saw us at our best.

Pega Community has detected you are using a browser which may prevent you from experiencing the site as intended. To improve your experience, please update your browser.

Close Deprecation Notice
Contact us