Support Article
pzBPQueueWorkItem activity step-9 has wrong value
SA-37275
Summary
In Pega-ProcessEngine:07-10-01 rule set, under Work-.pzBPQueueWorkItem activity step-9 has wrong value 'Pega-ProcessEngine_Branch_BP-RIB-POC:AgentCaseBulkProcessing'.
It should be Pega-ProcessEngine:AgentCaseBulkProcessing. Because of the wrong agent name PEGA Out-of-the-box (OOTB) Bulk Action background processing is not working.
Item gets queued in pr_sys_queues table but it's queued to agent: Branch_BP-RIB-POC:AgentCaseBulkProcessing which does not exist.
Error Messages
Item gets queued in pr_sys_queues table but it's queued to agent: Branch_BP-RIB-POC:AgentCaseBulkProcessing which doesn't exist
Steps to Reproduce
Use PEGA OOTB Bulk Action.
Root Cause
A defect in Pegasystems’ code or rules.
To process the bulk process items in back ground Pega uses Pega-ProcessEngine:AgentCaseBulkProcessing agent.
pzBPQueueWorkItem activity populates the agent queue details. Agent name is not properly listed in the queue page and it is causing the error.
Resolution
Apply HFix-34167.
In activity pzBPQueueWorkItem setting the agent name properly fixes the issue.
Agent name is set at Step 9 in this activity and the name should be:
Pega-ProcessEngine:AgentCaseBulkProcessing.
Published May 15, 2017 - Updated October 8, 2020
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