Support Article
SAML Authentication Service PostActivity cause blank screen
Summary
SAML Authentication and a PostAuthentication activity are configured for the Pega application.
The system redirects login requests to the SAML (SP) login screen and the SP authenticates the user correctly. However, a blank screen displays instead of the Pega portal.
Error Messages
Not Applicable
Steps to Reproduce
- Configure the Pega application to use SAML Authentication.
- Add a reference to the PostAuthentication activity on the SAML rule form.
- Click Save and log in.
Root Cause
An issue in the custom application code or rules.
Resolution
Here’s the explanation for the reported behavior. Reference the following Designer Studio Help file:
Configuring a SAML SSO authentication service > Specifying preauthentication and postauthentication activities for a SAML SSO authentication service
Refer to: https://community.pega.com/sites/ default/files/help_v81/procomhelpmain.htm?portalThreadName=OpenPortal_Developer&portalName=Developer#data-/data-admin-/data-admin-authservice/saml-specifying-pre-and-post-authentication-activities-tsk.htm#saml_specifying_pre_and_post_authentication_activities
Perform the following local-change:
Set the authentication result in pyAuthenticationPolicyResult to true to proceed with the authentication or set it to false to terminate the request.
For example,
tools.getRequestor().getRequestorPage().putString("pyAuthenticationPolicyResult", "true");
Published August 15, 2019 - Updated December 2, 2021
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