Skip to main content

This content has been archived and is no longer being updated. Links may not function; however, this content may be relevant to outdated versions of the product.

Support Article

SAML Authentication Service PostActivity cause blank screen

SA-79553

Summary



SAML Authentication and a PostAuthentication activity are configured for the Pega application.
The system redirects login requests to the SAML (SP) login screen and the SP authenticates the user correctly. However, a blank screen displays instead of the Pega portal.



Error Messages



Not Applicable


Steps to Reproduce

  1. Configure the Pega application to use SAML Authentication.
  2. Add a reference to the PostAuthentication activity on the SAML rule form.
  3. Click Save and log in.


Root Cause



An issue in the custom application code or rules.


Resolution



Here’s the explanation for the reported behavior. Reference the following Designer  Studio Help file:

Configuring a SAML SSO authentication service > Specifying preauthentication and postauthentication activities for a SAML SSO authentication service

Refer to: https://community.pega.com/sites/ default/files/help_v81/procomhelpmain.htm?portalThreadName=OpenPortal_Developer&portalName=Developer#data-/data-admin-/data-admin-authservice/saml-specifying-pre-and-post-authentication-activities-tsk.htm#saml_specifying_pre_and_post_authentication_activities

Perform the following local-change:

Set the authentication result in pyAuthenticationPolicyResult to true to proceed with the authentication or set it to false to terminate the request.

For example,


tools.getRequestor().getRequestorPage().putString("pyAuthenticationPolicyResult", "true");

Published August 15, 2019 - Updated December 2, 2021

Was this useful?

0% found this useful

Have a question? Get answers now.

Visit the Collaboration Center to ask questions, engage in discussions, share ideas, and help others.

Did you find this content helpful?

Want to help us improve this content?

We'd prefer it if you saw us at our best.

Pega Community has detected you are using a browser which may prevent you from experiencing the site as intended. To improve your experience, please update your browser.

Close Deprecation Notice
Contact us