Support Article
Segment criteria definition does not work
SA-25404
Summary
Defined Segment Criteria disappears from the Prospect Segment rule form after clicking on the Save button.
Error Messages
There are no any error messages either in tracer or in logs.
Steps to Reproduce
1. Create a new prospect segment. select a Prospect List.
2. Save and checkout.
3. In the Segment rule form under “Prospect List <Listname>” tab, click “Add criteria”.
4. In the selection Criteria Dialog select a “Defined Segment”.
5. Submit by clicking OK. The criteria gets added to segment rule form.
6. Click Save to save the segment rule. the Criteria disappears.
7. In case of Customer Segment the issue occurs after deleting all the existing criteria and then select a “Defined Segment” as criteria and save the rule.
Root Cause
A defect in Pegasystems’ code or rules. Issue with Segment visualization java script.
Resolution
Apply HFix-28300.
Published August 23, 2017 - Updated December 2, 2021
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