Skip to main content

This content has been archived and is no longer being updated. Links may not function; however, this content may be relevant to outdated versions of the product.

Support Article

Segments do not end running without any errors

SA-58764

Summary



In the Pega Marketing Audiences interface, error occurs on creating a segment with the basic criteria (user table contains 12 records) and running the segment. This occurs post Pega Marketing 7.31 update.


Error Messages



Not Applicable


Steps to Reproduce

  1. Update Pega Marketing 7.13 to Pega Marketing 7.31.
  2. Enter the Audience landing page.
  3. Create a segment.
  4. Add a simple criteria.
  5. Save the segment.
  6. Click the Run button.


Root Cause



A defect or configuration issue in the operating environment.

Segments are run by the including a queue item of the System-Queue-DeferredSegment class. A Deferred Segment Pega Marketing agent fetches and runs the segment.
By default, the Pega Marketing agents are disabled. Hence, all agent schedules created for corresponding Pega Node ID are also disabled.


Resolution



As a local-change, enable the agent schedule of the corresponding node ID for PegaMKT-Engine Agent Schedule rule.

 

Published December 29, 2018 - Updated December 2, 2021

Was this useful?

0% found this useful

Have a question? Get answers now.

Visit the Collaboration Center to ask questions, engage in discussions, share ideas, and help others.

Did you find this content helpful?

Want to help us improve this content?

We'd prefer it if you saw us at our best.

Pega Community has detected you are using a browser which may prevent you from experiencing the site as intended. To improve your experience, please update your browser.

Close Deprecation Notice
Contact us