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Support Article

Service case does not close after clicking the Wrap Up link

SA-57437

Summary



Post clicking the Wrap Up link, the Service case does not close.


Error Messages



Not Applicable


Steps to Reproduce

  1. Create an Interaction and launch the Service case.
  2. Click Wrap Up.
  3. Provide Interaction Feedback and Comments.
  4. Click Submit. Service case does not close.


Root Cause



An issue in the custom application code or rules.

Service cases were configured as temporary work objects which were not implemented correctly. WorkObject IDs were not generated for temporary work objects.

Resolution



Perform the following local-change: 

Invoke the CPMCheckAndSetTempID (this sets the temporary work object IDs) data transform rule from the pyDefault data transform of Customer Service case class.

Implement the same in the pyDefault data transform of PegaCA-Work class (this is generic).


 

Published August 24, 2018 - Updated December 2, 2021

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