Support Article
SOAP Connector failing while preparing the Request Header
SA-9320
Summary
User is seeing an ConnectorException on a SOAP Connector to the process after deploying to Production environment. In lower environments, it has worked correctly. Failure was related to PRPC preparing the Request payload.
Error Messages
com.pega.pegarules.pub.services.ConnectorException: Couldn't create OMElement from string value
Steps to Reproduce
Run Flow calling SOAP Connector
Root Cause
User has enabled SAML assertion generation on SOAP Request from a long time and it was working. It was only now that they were running via Batch and saw issues during SOAP Request creation. This issue was unique that after node startup, before any developer/user login to the portal, if you hit server which queues and then SOAP-Connect sends the request, invokeAxis2 was unable to create the request. If developer login, this issue was not replicable. Testing was done with SOAP UI tool.
Additional debugging statements were provided as the exception was not informative. It was identified the SOAP Request header had blank value for SAML header.
User suspected this to be with Dynamic System Setting (DSS) value during SAML generation activity. Though their tests were successful by hardcoding the values for DSS on one of the node, this failed on other nodes. With additional troubleshooting, it was identified that the issue was with SAML generation itself and not with DSS settings.
Resolution
Uncommenting Step-1 of GenerateSAML custom activity which had bootstrap code has resolved the issue.
Published April 30, 2015 - Updated October 8, 2020
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