Support Article
System cleaner agent does not start automatically.
SA-85881
Summary
The System cleaner agent does not start automatically.
Error Messages
Error in logs:
[fault (self-tuning)'] [STANDARD] [ ] [PegaCPMFS:07.13] (internal.async.AgentQueue) ERROR - runEnd(): Code-.SystemCleaner; true @ 0: Unable to reschedule agent due to computation errors. Invalid delay interval: -105914
[fault (self-tuning)'] [STANDARD] [ ] [rameworkREL:01.01.01] (rk_Interaction_Outbound.Action) INFO SP-PRPCAPP03.your_page.com|127.0.0.1|SOAP|CPMFSServices|Services|CreateOutboundInteraction|ABBB334E9B60C92B80DDE507D4C85E8A4 - PegaCPMFS-Work-Interaction-Outbound.CreateOutboundInteraction:: Parameter values:: AccountNumber [4284629048053065 ] | CifNbr [7592115] | Appl [ 3 ] | OutboundCommType [SMS] | EmailBody [Key Code: 7 | Treatment Name: SMS1_CC_DAY_1 ] | CallType [ ] | CustomerId [ 3378270 ]
[fault (self-tuning)'] [STANDARD] [ ] [rameworkREL:01.01.01] (rk_Interaction_Outbound.Action) INFO SP-PRPCAPP03.your_page.com|127.0.0.1|SOAP|CPMFSServices|Services|CreateOutboundInteraction|ABBB334E9B60C92B80DDE507D4C85E8A4 - PegaCPMFS-Work-Interaction-Outbound.CreateOutboundInteraction::Opening Active Collection Case for Account [ 4284629048053065 ]. Active Collection Case InsKey is [ TFKB-FW-COLLECTIONSFW-WORK-COLLECTION C-1472104]
Steps to Reproduce
Restart the application and check the System Cleaner agent.
Root Cause
The Agent Schedule was opened and the System Cleaner agent was scheduled. When the Advanced button was clicked, the popup window displayed that the agent was configured as Recurring for Every 0 Days.
Resolution
Perform the following local-change:
Update the Agent Schedule to Recur every one Day and save.
Published October 8, 2020
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