Support Article
Test Cases tab is not visible for certain rule types
SA-67107
Summary
The Test Cases tab does not display on the following rule types.
- Service Email
- Service File
- Declare Expression
- Service JMS
- Flow Action
- Harness
- Service MQ
- Map Value
- Service SOAP
- Parse Delimited
- Parse XML
- Section
Error Messages
Not Applicable
Steps to Reproduce
Open a rule form.
Root Cause
This behavior is as per Pega product design.
Resolution
The Pega Unit Testing feature is available only for certain rules types.
For the list of rules, refer to: https://community.pega.com/sites/default/files/help_v74/procomhelpmain.htm#designer-studio/testing-rules/test-cases/ds-pegaunit-test-cases-con.htm
Service SOAP rules had a Test Cases option when Automated Unit Testing (AUT) was used in earlier versions. There is an option to switch to the older version.
For more information, refer to:
https://community.pega.com/sites/default/files/help_v74/procomhelpmain.htm#designer-studio/testing-rules/ds-automated-rule-testing-landing-page-con.htm#Automated_Testing_landing_page https://community.pega.com/knowledgebase/articles/pega-722-and-later-behavior-when-switching-between-pegaunit-testing-and
Published January 4, 2019 - Updated December 2, 2021
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