Support Article
Unable to connect to Tibco JMS queues
SA-68011
Summary
Pega 7.3.1 is set up with JBoss Enterprise Application Platform (JBoss EAP) 7.1.0 GA.
Error occurs when connecting Java Message Service (JMS) listeners to the Tibco queues.
Error Messages
Caused by: com.pega.pegarules.pub.services.ServiceException: Failed to intialize response connection properties(JMS Factory lookup step) at com.pega.pegarules.integration.engine.internal.services.jms.JMSListener.initMDBResponseProperties(JMSListener.java:923) Caused by: javax.naming.AuthenticationException: Not permitted: authentication failed [Root exception is javax.jms.JMSSecurityException: authentication failed] at com.tibco.tibjms.naming.TibjmsContext.lookup(TibjmsContext.java:670) at com.tibco.tibjms.naming.TibjmsContext.lookup(TibjmsContext.java:491) at javax.naming.InitialContext.lookup(InitialContext.java:417) at javax.naming.InitialContext.lookup(InitialContext.java:417) at com.pega.pegarules.integration.engine.internal.services.jms.JMSListener.initMDBResponseProperties(JMSListener.java:920) ... 172 more Caused by: javax.jms.JMSSecurityException: authentication failed at com.tibco.tibjms.Tibjmsx.buildException(Tibjmsx.java:741)
Steps to Reproduce
Unknown
Root Cause
A defect or configuration issue in the operating environment.
Error occurs because authorization is enabled in Enterprise Management Service (EMS).
Resolution
Add the below settings in the Custom Properties tab of Java Naming and Directory Interface (JNDI) server instance.
- java.naming.security.principal
- java.naming.security.credentials
Published December 4, 2018 - Updated October 8, 2020
Have a question? Get answers now.
Visit the Collaboration Center to ask questions, engage in discussions, share ideas, and help others.