Support Article
Unable to see privately checked-out rules
SA-10825
Summary
The list of privately checked-out rules incorrectly shows "No checked out records" instead of the actual values. No error appears on the screen or in the PegaRULES log file.
Error Messages
Not Applicable.
Steps to Reproduce
- Perform a private edit of a rule.
- Click the "Private" icon to see the list of the privately checked-out rules.
- Observe that the rule from step 1 is not present in the list.
Root Cause
The root cause of this problem is an incorrect installation of the Pega 7.1.7 software.
Resolution
This issue is resolved through the following local-change:
- Add the missing database triggers.
- Run the following SQL update statements in the rules schema to get the triggers to fire to correctly populate the pr4_rule_vw table that missed the checked out rules:
UPDATE pr4_base SET pzinskey=pzinskey;
UPDATE pr4_fieldvalue SET pzinskey=pzinskey;
UPDATE pr4_rule SET pzinskey=pzinskey;
UPDATE pr4_rule_autotest SET pzinskey=pzinskey;
UPDATE pr4_rule_flow SET pzinskey=pzinskey;
UPDATE pr4_rule_property SET pzinskey=pzinskey;
UPDATE pr4_rule_sysgen SET pzinskey=pzinskey;
UPDATE pr4_rule_file SET pzinskey=pzinskey;
UPDATE pr4_rule_file_binary SET pzinskey=pzinskey;
UPDATE pr4_rule_requirement SET pzinskey=pzinskey;
UPDATE pr4_rule_usecase SET pzinskey=pzinskey;
UPDATE pr4_rule_shortcut SET pzinskey=pzinskey;
UPDATE pr4_rule_declarepages SET pzinskey=pzinskey;
UPDATE pr4_rule_ruleset SET pzinskey=pzinskey;
Published July 9, 2015 - Updated October 8, 2020
Have a question? Get answers now.
Visit the Collaboration Center to ask questions, engage in discussions, share ideas, and help others.