Skip to main content

This content has been archived and is no longer being updated. Links may not function; however, this content may be relevant to outdated versions of the product.

Support Article

URL in Knowledge articles do not open

SA-93750

Summary



On creating content that can include URLs in the Rich Text Editor (RTE) using Pega Knowledge Management, the URLs function intermittently. Though the URL works in a browser, the same link does not open and leads back to the article when accessed from the Knowledge article. For the links which do not open, the <a href> value displays as #.


Error Messages



Not Applicable


Steps to Reproduce

  1. Create a Knowledge article.
  2. Include a URL in the article.
  3. Provide a SharePath URL (such as, the URL to a specific file). 


Root Cause



This behavior is as per Pega product design: Pega Platform 8.2 version of the RTE to avoid XSS attacks.
Hence, URLs with the parentheses '(' or ')' do not work.



Resolution



Here’s the explanation for the reported behavior: 

The Markup generated for the hyperlink is as below for URLs which have '(' or ')' in them.


"<a href="#" target="_blank">

This is due to a change made in Pega Platform 8.2 (and later) to overcome XSS vulnerabilities and  security attacks with the presence of parenthesis '(' or ')'.
If certain special characters are present in an Anchor href tag, the links are sanitized to #.

As a local-change, avoid having document file names with parentheses such that the link does not have brackets in it.

Published July 22, 2020 - Updated December 2, 2021

Was this useful?

0% found this useful

Have a question? Get answers now.

Visit the Collaboration Center to ask questions, engage in discussions, share ideas, and help others.

Did you find this content helpful?

Want to help us improve this content?

We'd prefer it if you saw us at our best.

Pega Community has detected you are using a browser which may prevent you from experiencing the site as intended. To improve your experience, please update your browser.

Close Deprecation Notice
Contact us