Support Article
URL in Knowledge articles do not open
SA-93750
Summary
On creating content that can include URLs in the Rich Text Editor (RTE) using Pega Knowledge Management, the URLs function intermittently. Though the URL works in a browser, the same link does not open and leads back to the article when accessed from the Knowledge article. For the links which do not open, the <a href> value displays as #.
Error Messages
Not Applicable
Steps to Reproduce
- Create a Knowledge article.
- Include a URL in the article.
- Provide a SharePath URL (such as, the URL to a specific file).
Root Cause
This behavior is as per Pega product design: Pega Platform 8.2 version of the RTE to avoid XSS attacks.
Hence, URLs with the parentheses '(' or ')' do not work.
Resolution
Here’s the explanation for the reported behavior:
The Markup generated for the hyperlink is as below for URLs which have '(' or ')' in them.
"<a href="#" target="_blank">
This is due to a change made in Pega Platform 8.2 (and later) to overcome XSS vulnerabilities and security attacks with the presence of parenthesis '(' or ')'.
If certain special characters are present in an Anchor href tag, the links are sanitized to #.
As a local-change, avoid having document file names with parentheses such that the link does not have brackets in it.
Published July 22, 2020 - Updated December 2, 2021
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