Support Article
Visual Indicator missing for Open Task or Intent or SR
SA-23494
Summary
The indicator arrow is missing for the focused intent in the Interaction with Pega 7.1.4.
Error Messages
No error message.
Steps to Reproduce
1.Create a Phone call Interaction.
2.Navigate to Member 360 screen.
3.Add any intent and observe that the blue colored box does not have indicator arrow to show in focus intent.
Root Cause
In the Tracer logs the ‘.IsSelected’ of ‘D_CPMServiceCaseRecents.pxResults’ property is true at developer's end which is responsible to get the arrow.
Even though the .IsSelected is true, in UI the arrow is not coming. So identified it can be a problem with CSS.
Checked the CSS of the divs at developer end and compared it with in-house system.
For the href tag, it is picking position:relative at their end so eliminating all the other CSS responsible for the arrow.
By observing their skin, found that the ‘cpm-overrides’ CSS file is customized at their end and the below code snippet is customized.
.task-selected a {
position: relative;
}
But in Out-of-the-box (OOTB) ‘cpm-overrides’ file, that is commented.
With position:relative, it is pointing the arrow but in background to the Intent task. So one cannot see it. The position must be absolute to make the arrow element relative to its parent div(Intent).
Resolution
Comment the CSS as below in cpm-overrides CSS file:
.task-selected a {
/* commented out to re-enable the ::after pseudo-element after adding overflow:hidden; to the links
position: relative; */
}
Published May 24, 2016 - Updated December 2, 2021
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