Support Article
Worklist opened from Mygroup and Bulk Processing are not same
SA-39541
Summary
User's application is an upgrade from PRPC 5.x to Pega 7.1.9.
The number of cases for each operator is not matching when user tries to view from “View List For“ drop-down field from My group tab and 'Transfer work' from 'Select Operator' drop-down field under Bulk Processing tab.

Error Messages
Not Applicable
Steps to Reproduce
1. Login to application.
2. Launch CaseManager Portal.
Note: Use PRPC 5.x bulk processing harness for Bulk processing. Modify pyCaseMgroptions navigation rule to refer harness MgrHome).
3. Launch the BulkAction screen.
4. Select the Work Basket (WB) (default@sae) from MyGroup and note the retrieved results.
5. Select the same WB(default@sae) from 'TransferWorkFrom' drop-down, and check the retrieved results.
Root Cause
An issue in the custom application code or rules By default, the maximum of number of records the listview BulkProcessList can retrieve is hardcoded as 1000.
Also, all the assignments does not get listed, during bulk processing:
- Bulkprocess screen will list only those assignments for which 'transfer' local action is configured.
- Also getBulkProcessContent activity will filter out those assignments for which same hashkey is present (which is a combination of flowname,flowtype,assignmentkey).
Resolution
Modify the maximum value to 10000 in the BulkProcessList view:
Published August 14, 2017 - Updated October 8, 2020
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